字符串专题第22组题解

A - 雷同检测

考试的时候老师最讨厌有人抄袭了。自从有了电子评卷,老师要查找雷同卷,就容易多了,只要将两个人的答案输入计算机,进行逐个字符的比对,把相同的位置都找出来,就一目了然了。

输入格式

2 行,每行包含一串字符(长度不超过 200)。

输出格式

1 行,包含若干个以空格分隔的数字,表示出现相同字符的位置。

Sample Input

1
2
I am  suantoujun.
I am huayemei.

Sample Output

1
1 2 3 4 5 6 8 9
1
2
3
4
5
6
7
8
9
10
#include<stdio.h>
int main()
{
char a[210],b[210];
gets(a),gets(b);
for(int i=0;a[i]!='\0';i++)
if(a[i]==b[i])
printf("%d ",i+1);
return 0;
}

B - 首字母大写

对一个字符串中的所有单词,如果单词的首字母不是大写字母,则把单词的首字母变成大写字母。在字符串中,单词之间通过空白符分隔,空白符包括:空格(‘ ‘)、制表符(‘\t’)、回车符(‘\r’)、换行符(‘\n’)。

Input

输入一行:待处理的字符串(长度小于80)。

Output

输出一行:转换后的字符串。

Sample Input

1
if so, you already have a google account. you can sign in on the right.

Sample Output

1
If So, You Already Have A Google Account. You Can Sign In On The Right.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include<stdio.h>
#include<string.h>
int main()
{
char a[90];
scanf("%[^\n]",a);
if(a[0]>='a'&&a[0]<='z')
a[0]-=32;
for(int i=1;i<strlen(a)-1;i++)
if(a[i]==' '&&a[i+1]>='a'&&a[i+1]<='z')
a[i+1]-=32;
printf("%s",a);
return 0;
}

C - 大小写转换

读入一些字符串,将其中的小写字母转成大写字母(其他字符不变)。

输入

输入为多行,每行为一个字符串,字符串只由字母和数字组成,长度不超过80。输入以“End of file”结束。

输出

对于每行输入,输出转换后的字符串。

输入示例

1
2
3
Hello
ICPC2004
12345abcde

输出示例

1
2
3
HELLO
ICPC2004
12345ABCDE
1
2
3
4
5
6
7
8
9
10
11
12
#include<stdio.h>
int main()
{
char a[90];
while(scanf("%s",a)==1){
for(int i=0;a[i]!='\0';i++)
if(a[i]>='a'&&a[i]<='z')
a[i]-=32;
printf("%s\n",a);
}
return 0;
}

D - 数字反转

给定一个整数,请将该数各个位上数字反转得到一个新数。新数也应满足整数的常见形式,即除非给定的原数为零,否则反转后得到的新数的最高位数字不应为零(参见样例 2)。

输入格式

输入共 1 行,一个整数 N。

输出格式

输出共 1 行,一个整数,表示反转后的新数。

数据范围

-1,000,000,000 <= N <= 1,000,000,000−1,000,000,000 <= N <= 1,000,000,000。

Sample Input

1
123

Sample Output

1
321

Sample Input 2

1
-380

Sample Output 2

1
-83
1
2
3
4
5
6
7
8
9
10
11
#include<stdio.h>
int main()
{
int n,sum=0;
scanf("%d",&n);
while(n){
sum=sum*10+n%10;
n/=10;
}
printf("%d",sum);
}

E - 删除单词后缀

给定一个单词,如果该单词以erly或者ing后缀结尾, 则删除该后缀(题目保证删除后缀后的单词长度不为 0),否则不进行任何操作。

输入格式

输入一行,包含一个单词(单词中间没有空格,每个单词最大长度为 32)。

输出格式

输出按照题目要求处理后的单词。

Sample Input

1
referer

Sample Output

1
refer
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include<stdio.h>
#include<string.h>
int main()
{
char a[40];
int l;
scanf("%s",a);
l=strlen(a)-1;
if(a[l]=='r'&&a[l-1]=='e'||a[l]=='y'&&a[l-1]=='l')
a[l-1]='\0';
if(a[l-2]=='i'&&a[l-1]=='n'&&a[l]=='g')
a[l-2]='\0';
printf("%s",a);
return 0;
}

F - 判断字符串是否为回文

输入一个字符串,输出该字符串是否回文。回文是指顺读和倒读都一样的字符串。

输入格式

输入为一行字符串(字符串中没有空白字符,字符串长度不超过 100)。

输出格式

如果字符串是回文,输出"yes";否则,输出"no"

Sample Input

1
abcdedcba

Sample Output

1
yes
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<stdio.h>
#include<string.h>
int main()
{
char a[110];
int len,i;
scanf("%s",a);
len=strlen(a)-1;
for(i=0;i<=len/2;i++)
if(a[len-i]!=a[i])
break;
if(i<=len/2)
printf("no");
else
printf("yes");
return 0;
}

G - 基础数据结构——栈(1)

给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

输入格式

输入数据有多组,每组数据不超过100个字符并含有( ,) ,[, ],{, }一个或多个。处理到文件结束。

输出格式

如果匹配就输出"yes",不匹配输出"no"

Sample Input

1
2
sin(20+10)
{[}]

Sample Output

1
2
yes
no
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <bits/stdc++.h>
using namespace std;
char s[60],c[60];
int main()
{
while(gets(s)/*!=NULL*/){
int i,top=0,l=strlen(s);//top代表栈顶
for(i=0;i<l;i++){
if(s[i]=='('||s[i]=='['||s[i]=='{'){
c[top]=s[i];
top++;//遇到前括号就入栈
}
else if(s[i]==')'||s[i]==']'||s[i]=='}'){
if(s[i]==c[top-1]+1||s[i]==c[top-1]+2){//根据ascll码值找关系(40,41,91,93,123,125)
top--;//匹配成功就一块出栈
}
else
break;
}
}
if(i==l&&!top)//最后栈空就说明全匹配成功了
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}

H - 字典序

给你两个不同的字符串,如果第一个字符串的字典序小于第二个字符串,则输出YES,如果第一个字符串的字典序大于第二个字符串,则输出NO。

Input

两行。第一行一个字符串,第二行一个字符串。保证字符串的长度不超过10000。保证两个字符串不完全相等。

Output

如果第一个字符串的字典序小于第二个字符串,则输出YES,如果第一个字符串的字典序大于第二个字符串,则输出NO。

Sample Input

1
2
abc
abe

Sample Output

1
YES
1
2
3
4
5
6
7
8
9
10
11
12
#include<stdio.h>
#include<string.h>
char a[10010],b[10010];
int main()
{
scanf("%s%s",a,b);
if(strcmp(a,b)>0)
printf("NO");
else
printf("YES");
return 0;
}

I - 验证子串

输入两个字符串,验证其中一个串是否为另一个串的子串。

输入格式

输入两个字符串, 每个字符串占一行,长度不超过 200 且不含空格。

输出格式

若第一个串 s1 是第二个串 s2 的子串,则输出"(s1) is substring of (s2)"

否则,若第二个串 s2是第一个串s1的子串,输出"(s2) is substring of (s1)"

否则,输出"No substring"

Sample Input

1
2
abc
dddncabca

Sample Output

1
abc is substring of dddncabca
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#include<stdio.h>
#include<string.h>
int main()
{
int l1,l2;
char s1[210],s2[210];
gets(s1),gets(s2);
l1=strlen(s1),l2=strlen(s2);
if(l1<l2&&strstr(s2,s1))
printf("%s is substring of %s",s1,s2);
else if(l1>l2&&strstr(s1,s2))
printf("%s is substring of %s",s2,s1);
else
printf("No substring");
return 0;
}

J - 子串查找

题目描述

这是一道模板题。

给定一个字符串 A 和一个字符串 B,求 B 在 A 中的出现次数。AB 中的字符均为英语大写字母或小写字母。

A 中不同位置出现的 B 可重叠。

输入格式

输入共两行,分别是字符串 A 和字符串 B。

输出格式

输出一个整数,表示 B 在 A 中的出现次数。

样例

Input Output
zyzyzyz zyz 3

数据范围与提示

1 <= A, B的长度 <=10^6,A、B 仅包含大小写字母。

kmp

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include<bits/stdc++.h>
using namespace std;
#define M 1000000
char s[M],p[M];
int nxt[M];
void kmp(){
int len=strlen(p);
for(int i=1,j=0;p[i];i++){
while(j&&p[j]!=p[i])
j=nxt[j];
nxt[i+1]=p[j]==p[i]?++j:0;
}
int tot=0;
for(int i=0,j=0;s[i];i++){
while(j&&p[j]!=s[i])
j=nxt[j];
if (p[j]==s[i]&&++j==len){
tot++;
j=nxt[j];
}
}
printf("%d",tot);
}
int main()
{
scanf("%s %s",s,p);
kmp();
return 0;
}

K - 剪花布条

题目描述

一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?

输入格式

输入数据为多组数据,读取到 # 字符时结束。每组数据仅有一行,为由空格分开的花布条和小饰条。花布条和小饰条都是用可见 ASCII 字符表示的,不会超过 1000 个字符。

注意:这个 # 应为单个字符。若某字符串开头有 #,不意味着读入结束!

输出格式

对于每组数据,输出一行一个整数,表示能从花纹布中剪出的最多小饰条个数。

样例

Input Output
abcde a3 aaaaaa aa # 0 3

数据范围与提示

对于全部数据,字符串长度 ≤1000。

1.用string代替char

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s,t;
while(cin>>s){
if(s[0]=='#'&&s[1]=='\0')
break;
cin>>t;
int cnt=0;
for(int i=0; i<s.size();i++){
int j=0,k=i;
while(s[k]==t[j]&&k<s.size()){
++k;++j;
}
if(j==t.size()){
cnt++;
i=k-1;
}
}
cout<<cnt<<endl;
}
return 0;
}

2.STL里的find函数

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s,t;
while(cin>>s&&!(s[0]=='#'&&s[1]=='\0')){
cin>>t;
int cnt=0;
while (s.find(t)!=string::npos){ //s.find(t)找不到会返回string::npos
cnt++;
s.erase(s.find(t),t.size()); //s.erase将已经找到的花布条剪掉
}
cout<<cnt<<endl;
}
}

L - 最长回文子串

输入一个字符串Str,输出Str里最长回文子串的长度。

回文串:指aba、abba、cccbccc、aaaa这种左右对称的字符串。

串的子串:一个串的子串指此(字符)串中连续的一部分字符构成的子(字符)串
例如 abc 这个串的子串:空串、a、b、c、ab、bc、abc

输入格式

输入Str(Str的长度 <= 1000)

输出格式

输出最长回文子串的长度L。

Sample Input

1
daabaac

Sample Output

1
5

中点扩散

O(n^2),为了代码简洁好看些doge,O(n)还是用哈希吧

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<bits/stdc++.h>
using namespace std;
int main()
{
string str;
getline(cin,str);
int res=0;
for(int i=0;i<str.length();i++){
int l=i-1,r=i+1;//这里要考虑到回文子串长度可能是偶数或奇数
while(l>=0&&r<str.length()&&str[l]==str[r]){
l--;
r++;
}
res=max(res,r-l-1);
l=i,r=i+1;
while(l>=0&&r<str.length()&&str[l]==str[r]){
l--;
r++;
}
res=max(res,r-l-1);
}
cout<<res<<endl;
return 0;
}